Search Unity

  1. Check out our Unite Austin 2017 YouTube playlist to catch up on what you missed. More videos coming soon.
    Dismiss Notice
  2. Unity 2017.2 is now released.
    Dismiss Notice
  3. The Unity Gear Store is here to help you look great at your next meetup, user group or conference. With all new Unity apparel, stickers and more!
    Dismiss Notice
  4. Introducing the Unity Essentials Packs! Find out more.
    Dismiss Notice
  5. Want to see the most recent patch releases? Take a peek at the patch release page.
    Dismiss Notice
  6. Unity 2017.3 beta is now available for download.
    Dismiss Notice

Cloud Build Failed During LFS Clone

Discussion in 'Unity Cloud Build' started by Wuzseen, Apr 8, 2017.

  1. Wuzseen

    Wuzseen

    Joined:
    Apr 19, 2011
    Posts:
    19
    Since updating our project to 5.6 it has started failing during clone in Cloud build:

    GIT: Error during clone: git lfs clone '--branch' 'master' '--recursive' '--' 'gitURL' '/BUILD_PATH/sweet-roll-studio-llc.dream-links.default-linux-desktop-64-bit' 2>&1:

    We hadn't done any cloud builds for about 2 weeks prior to 5.6 launching so I'm unsure if it is a problem with our project our cloud build.

    Any ideas? It is a pulling from a GitLab CE instance I manage.

    In the full log (can provide text file if necessary), you can see the project gets successfully downloaded, then it hits the error above.
     
  2. unitychrism

    unitychrism

    Unity Technologies

    Joined:
    Sep 16, 2015
    Posts:
    122
    Hello there,

    I will reach out individually to receive more information, please standby. Once resolved, I will update this thread if there is any information relevant to other users' experience while building Git LFS projects.

    Thanks!
     
  3. loafer

    loafer

    Joined:
    May 23, 2013
    Posts:
    3
    was this resolved?
     
  4. MaxFrax96

    MaxFrax96

    Joined:
    Nov 18, 2012
    Posts:
    8
    Is someone experiencing the same issue now?
     
  5. Mike_Olv

    Mike_Olv

    Joined:
    Sep 11, 2017
    Posts:
    1
    I do have the same issue, do you use a submodule in your git repository ?
     
  6. zkw

    zkw

    Joined:
    Sep 16, 2013
    Posts:
    105
    Same issue here. Project doesn't use LFS by the way.
     
  7. IsmaeelShujat

    IsmaeelShujat

    Joined:
    May 18, 2017
    Posts:
    1

    Was this ever resolved? if yes kindly let us know
     
  8. cabrendan

    cabrendan

    Joined:
    Jan 10, 2013
    Posts:
    10
    I'm trying out UCB for the first time and I'm also having LFS issues. I also am a Pro user, but was unable to create a support ticket.

    Description of issue: UCB fails to fully clone project

    Unity version: 2017.1.1f1

    XCode version: n/a

    Source control: git

    Local build platform: Windows 64 bit

    Build target: Windows 64 bit

    Build log (relevant chunk [urls have been obfuscated]):
    14: GIT: Checkout project...
    15: GIT: Checking out ssh://git@mygitlabserver.com:5000/Proj/proj-unity.git/master
    16: [13:29:11] error: failed to fetch some objects from 'https://mygitlabserver.com/Proj/proj-unity.git/info/lfs'
    17: GIT: Error during clone: git lfs clone '--branch' 'master' '--recursive' '--' 'ssh://git@mygitlabserver.com:5000/Proj/proj-unity.git' '/BUILD_PATH/mygitlabserver.proj.default-windows-desktop-64-bit' 2>&1:

    An unusual thing about the setup is that it's forwarding ssh connections through port 5000. However, running the git lfs clone command works just fine for the standard git for windows installs that my coworkers and I have.
     
  9. cabrendan

    cabrendan

    Joined:
    Jan 10, 2013
    Posts:
    10
    Yeah, nevermind. My setup is weird and you shouldn't be expected to support it :p

    the 'git lfs clone' commands always fail when run externally because my server's lfs setup doesn't understand the redirection nonsense I'm doing.